Google AdSense

Samstag, 7. Januar 2012

Zurück zum Arduino-Messaufbau

Getrieben durch die letsten Enttäuschungen und mit dem Zeitdruck im Nacken, habe ich mich wieder  dem Arduinoaufbau zugewendet.
Der Aufbau ist im Prinzip der gleiche wie bisher, nur das die Spannungsversorgung (Manson NSP-2050) und der Strommesser auf einen +/- 30A geändert habe.
Eingestellt sind die Wert so, dass bei 3,5V Zellspannung und der Unterschreitung von 3,0A ein Relais öffnet und den Ladevorgang abbricht.
Auf dem Bild etwas schwer zu erkennen ist, dass die Werte auf dem Multimeter (UNI-T UT61E) und dem Display des Arduino ziemlich nah zusammen liegen.
Gemessen wird hier an den Stromklammern an den Zellpolen.

Anfangs habe ich den Strom des Netzgeräts auf Maximum gestellt (~6A). Damit das klappt, muss die Ausgangsspannung auf etwa 5V steigen, die Zellspannung ist allerdings weiterhin ~3,4V und langsam steigend.
Und genau hier liegt der Hund des iChargers begraben, denke ich.
Wie auch das Netzteil jetzt ~5V anzeigt bei 6A Ladestrom, wird der Junsi iCharger auch "seine" Spannung als Grundlage nehmen und daher kommen an der Zelle nie die eingestellten Werte an.
Darum wird der Ladevorgang abgebrochen.

Genau so verhält es sich, wenn ich die Spannung am Manson Netzteil auf 3,5V einstelle, denn dann geht der Strom auf fast Null zurück, auch wenn die Zelle selbst noch nicht die Spannung erreicht hat.

Um den Akku auf 3,5V zu laden bei 3A Ladestrom, muss ich also die Spannungsquelle deutlich höher einstellen und ggf. justieren.

Im Moment messe ich in meinem Schaltkreis (bestätigt durch Multimeter und Strommesszange) 3,450V und 3,000A, auf dem Display des Netzteils steht "4,21V" und "4,264A" im C.C. Modus (Konstantstrom).

Ich bin gespannt, wann das Relais öffnet ...

Arduino Sketch Download (.zip)

Kommentare:

  1. Hallo,

    vielen Dank für den Arduino Sketch ...

    LG
    Micro

    AntwortenLöschen
  2. Gern. Wenn Du den Code verbessert oder erweitert hast, stelle ich die Version gern dazu.

    AntwortenLöschen

Vielen Dank.